AcadBlockClassIOdaBlock_AttachExternalReference Method
|
Namespace: BricscadDb
Assembly: Interop.BricscadDb (in
Interop.BricscadDb.dll) Version: 21.0.0.0
Syntax
public virtual AcadExternalReference IOdaBlock_AttachExternalReference(
string PathName,
string Name,
Object InsertionPoint,
double Xscale,
double Yscale,
double Zscale,
double Rotation,
bool bOverlay,
[OptionalAttribute] Object Password
)
Public Overridable Function IOdaBlock_AttachExternalReference (
PathName As String,
Name As String,
InsertionPoint As Object,
Xscale As Double,
Yscale As Double,
Zscale As Double,
Rotation As Double,
bOverlay As Boolean,
<OptionalAttribute> Password As Object
) As AcadExternalReference
public:
virtual AcadExternalReference^ IOdaBlock_AttachExternalReference(
[InAttribute] String^ PathName,
[InAttribute] String^ Name,
[InAttribute] Object^ InsertionPoint,
[InAttribute] double Xscale,
[InAttribute] double Yscale,
[InAttribute] double Zscale,
[InAttribute] double Rotation,
[InAttribute] bool bOverlay,
[OptionalAttribute] [InAttribute] Object^ Password
)
abstract IOdaBlock_AttachExternalReference :
PathName : string *
Name : string *
InsertionPoint : Object *
Xscale : float *
Yscale : float *
Zscale : float *
Rotation : float *
bOverlay : bool *
[<OptionalAttribute>] Password : Object -> AcadExternalReference
override IOdaBlock_AttachExternalReference :
PathName : string *
Name : string *
InsertionPoint : Object *
Xscale : float *
Yscale : float *
Zscale : float *
Rotation : float *
bOverlay : bool *
[<OptionalAttribute>] Password : Object -> AcadExternalReference
Parameters
- PathName
- Type: SystemString
- Name
- Type: SystemString
- InsertionPoint
- Type: SystemObject
- Xscale
- Type: SystemDouble
- Yscale
- Type: SystemDouble
- Zscale
- Type: SystemDouble
- Rotation
- Type: SystemDouble
- bOverlay
- Type: SystemBoolean
- Password (Optional)
- Type: SystemObject
Return Value
Type:
AcadExternalReference
Implements
IOdaBlockAttachExternalReference(String, String, Object, Double,
Double, Double, Double, Boolean, Object)
See Also