NurbSurface Constructor (Int32, Int32, Boolean, Int32, Int32,
Point3dCollection, DoubleCollection, KnotCollection,
KnotCollection)
|
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public NurbSurface(
int uDegree,
int vDegree,
bool rational,
int uNumControlPoints,
int vNumControlPoints,
Point3dCollection ctrlPts,
DoubleCollection weights,
KnotCollection uKnots,
KnotCollection vKnots
)
Public Sub New (
uDegree As Integer,
vDegree As Integer,
rational As Boolean,
uNumControlPoints As Integer,
vNumControlPoints As Integer,
ctrlPts As Point3dCollection,
weights As DoubleCollection,
uKnots As KnotCollection,
vKnots As KnotCollection
)
public:
NurbSurface(
int uDegree,
int vDegree,
bool rational,
int uNumControlPoints,
int vNumControlPoints,
Point3dCollection^ ctrlPts,
DoubleCollection^ weights,
KnotCollection^ uKnots,
KnotCollection^ vKnots
)
new :
uDegree : int *
vDegree : int *
rational : bool *
uNumControlPoints : int *
vNumControlPoints : int *
ctrlPts : Point3dCollection *
weights : DoubleCollection *
uKnots : KnotCollection *
vKnots : KnotCollection -> NurbSurface
Parameters
- uDegree
- Type: SystemInt32
- vDegree
- Type: SystemInt32
- rational
- Type: SystemBoolean
- uNumControlPoints
- Type: SystemInt32
- vNumControlPoints
- Type: SystemInt32
- ctrlPts
- Type: Teigha.GeometryPoint3dCollection
- weights
- Type: Teigha.GeometryDoubleCollection
- uKnots
- Type: Teigha.GeometryKnotCollection
- vKnots
- Type: Teigha.GeometryKnotCollection
See Also