CircularArc2dGetTangent Method (Point2d, Tolerance)

Retrieves the tangent line at the specified point according to the specified tolerance.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public Line2d GetTangent(
        Point2d point,
        Tolerance tolerance
)

Parameters

point
Type: Teigha.GeometryPoint2d
[in] Point at which the tangent line is calculated.
tolerance
Type: Teigha.GeometryTolerance
[in] Geometry tolerance.

Return Value

Type: Line2d
Tangent 2D line represented by the Line2d class.
See Also

©  Bricsys NV. All rights reserved.