CircularArc3dIntersectWith Method (LinearEntity3d, Tolerance)

Retrieves intersection points between this circular arc and the passed line.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public Point3d[] IntersectWith(
        LinearEntity3d line,
        Tolerance tolerance
)

Parameters

line
Type: Teigha.GeometryLinearEntity3d
[in] A 3D line to intersect with.
tolerance
Type: Teigha.GeometryTolerance
[in] Geometric tolerance.

Return Value

Type: Point3d
Array of intersection points.
See Also

©  Bricsys NV. All rights reserved.