DatabaseSaveAs Method (String, DwgVersion, Boolean, Int32)

Saves content of the currently active database according to the passed arguments.
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public void SaveAs(
        string fileName,
        DwgVersion version,
        bool saveThumbnailImage,
        int dxfPrecision
)

Parameters

fileName
Type: SystemString
[in] File name to write the database to. File extension is not appended automatically.
version
Type: Teigha.DatabaseServicesDwgVersion
[in] A file version to which to save the file.
saveThumbnailImage
Type: SystemBoolean
[in] Flag that indicates whether to save a thumbnail image.
dxfPrecision
Type: SystemInt32
[in] .dxf file decimal digits precision. Currently ignored; a value of 16 is used.
See Also

©  Bricsys NV. All rights reserved.