Curve2dIsOn Method (Point2d, Double, Tolerance)
|
Checks whether a specified point lies on this
curve.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public bool IsOn(
Point2d point,
out double value,
Tolerance tolerance
)
Public Function IsOn (
point As Point2d,
<OutAttribute> ByRef value As Double,
tolerance As Tolerance
) As Boolean
public:
bool IsOn(
Point2d point,
[OutAttribute] double% value,
Tolerance tolerance
)
member IsOn :
point : Point2d *
value : float byref *
tolerance : Tolerance -> bool
Parameters
- point
- Type: Teigha.GeometryPoint2d
[in] Point to be checked.
- value
- Type: SystemDouble
[out] Receives the parameter value that corresponds to a point on
the curve.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
Boolean
true if the specified point lies on this
curve,
false otherwise.
See Also