Polyline2d Constructor (Poly2dType, Point3dCollection, Double,
Boolean, Double, Double, DoubleCollection)
|
Initializes a new instance of the
Polyline2d
class
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Polyline2d(
Poly2dType type,
Point3dCollection vertices,
double elevation,
bool closed,
double startWidth,
double endWidth,
DoubleCollection bulges
)
Public Sub New (
type As Poly2dType,
vertices As Point3dCollection,
elevation As Double,
closed As Boolean,
startWidth As Double,
endWidth As Double,
bulges As DoubleCollection
)
public:
Polyline2d(
Poly2dType type,
Point3dCollection^ vertices,
double elevation,
bool closed,
double startWidth,
double endWidth,
DoubleCollection^ bulges
)
new :
type : Poly2dType *
vertices : Point3dCollection *
elevation : float *
closed : bool *
startWidth : float *
endWidth : float *
bulges : DoubleCollection -> Polyline2d
Parameters
- type
- Type: Teigha.DatabaseServicesPoly2dType
- vertices
- Type: Teigha.GeometryPoint3dCollection
- elevation
- Type: SystemDouble
- closed
- Type: SystemBoolean
- startWidth
- Type: SystemDouble
- endWidth
- Type: SystemDouble
- bulges
- Type: Teigha.GeometryDoubleCollection
See Also