DatabaseGetObjectId Method

Retrieves the object ID corresponding to the specified handle object in this database.
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public ObjectId GetObjectId(
        bool createIfNotFound,
        Handle objHandle,
        int identifier
)

Parameters

createIfNotFound
Type: SystemBoolean
[in] Flag that specifies whether to create an object if not found.
objHandle
Type: Teigha.DatabaseServicesHandle
[in] Database handle of the searched object.
identifier
Type: SystemInt32
[in] External reference identifier. Currently not supported.

Return Value

Type: ObjectId
Identifier of a found or created object.
See Also

©  Bricsys NV. All rights reserved.