OrdinateDimension Constructor (Boolean, Point3d, Point3d,
String, ObjectId)
|
Constructor. Creates an OrdinateDimension
object with specified parameters.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public OrdinateDimension(
bool useXAxis,
Point3d definingPoint,
Point3d leaderEndPoint,
string dimText,
ObjectId dimStyle
)
Public Sub New (
useXAxis As Boolean,
definingPoint As Point3d,
leaderEndPoint As Point3d,
dimText As String,
dimStyle As ObjectId
)
public:
OrdinateDimension(
bool useXAxis,
Point3d definingPoint,
Point3d leaderEndPoint,
String^ dimText,
ObjectId dimStyle
)
new :
useXAxis : bool *
definingPoint : Point3d *
leaderEndPoint : Point3d *
dimText : string *
dimStyle : ObjectId -> OrdinateDimension
Parameters
- useXAxis
- Type: SystemBoolean
Defines whether the x-axis or y-axis distance between the origin
and the definition point is measured. Pass the true value to
measure the x-axis distance or false for the y-axis distance.
- definingPoint
- Type: Teigha.GeometryPoint3d
The point for which the distance is measured.
- leaderEndPoint
- Type: Teigha.GeometryPoint3d
End point of the extension line.
- dimText
- Type: SystemString
Dimension text to replace the measured value text.
- dimStyle
- Type: Teigha.DatabaseServicesObjectId
ObjectId of the dimension style that is used to draw the dimension
entity.
See Also