CircularArc2dIntersectWith Method (LinearEntity2d)
|
Retrieves the intersection points between this
circular arc and the passed line.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Point2d[] IntersectWith(
LinearEntity2d line
)
Public Function IntersectWith (
line As LinearEntity2d
) As Point2d()
public:
array<Point2d>^ IntersectWith(
LinearEntity2d^ line
)
member IntersectWith :
line : LinearEntity2d -> Point2d[]
Parameters
- line
- Type: Teigha.GeometryLinearEntity2d
[in] A 2D line to intersect with.
Return Value
Type:
Point2d
Array of intersection points.
See Also