Curve2dIsDegenerate Method (Entity2d, Tolerance)
|
Checks whether this curve is degenerate and
returns the type of entity that the curve degenerates to (if
degenerate).
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public bool IsDegenerate(
out Entity2d result,
Tolerance tolerance
)
Public Function IsDegenerate (
<OutAttribute> ByRef result As Entity2d,
tolerance As Tolerance
) As Boolean
public:
bool IsDegenerate(
[OutAttribute] Entity2d^% result,
Tolerance tolerance
)
member IsDegenerate :
result : Entity2d byref *
tolerance : Tolerance -> bool
Parameters
- result
- Type: Teigha.GeometryEntity2d
[out] Retrieves the type of degenerate entity.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
Boolean
true if this curve is degenerate,
false otherwise.
See Also