ApplicationShowModalDialog Method (IWin32Window, Form, Boolean)
|
Shows a modal dialog. When ShowModalDialog is
used, an event is attached to preserve the location and size of
dialog
Namespace: Bricscad.ApplicationServices
Assembly: BrxMgd (in BrxMgd.dll) Version:
21.0.0.15598
Syntax
public static DialogResult ShowModalDialog(
IWin32Window owner,
Form form,
bool persist
)
Public Shared Function ShowModalDialog (
owner As IWin32Window,
form As Form,
persist As Boolean
) As DialogResult
public:
static DialogResult ShowModalDialog(
IWin32Window^ owner,
Form^ form,
bool persist
)
static member ShowModalDialog :
owner : IWin32Window *
form : Form *
persist : bool -> DialogResult
Parameters
- owner
- Type: System.Windows.FormsIWin32Window
Form Owner
- form
- Type: System.Windows.FormsForm
Form to Show
- persist
- Type: SystemBoolean
option to persist size and location
Return Value
Type:
DialogResult
System::Windows::Forms::DialogResult
See Also