DatabaseInsert Method (String, Database, Boolean)

Copies the content of a specified database to this database.
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public ObjectId Insert(
        string blockName,
        Database dataBase,
        bool preserveSourceDatabase
)

Parameters

blockName
Type: SystemString
[in] Name for the newly created block table record.
dataBase
Type: Teigha.DatabaseServicesDatabase
[in] Source database to copy data from.
preserveSourceDatabase
Type: SystemBoolean
[in] Flag that specifies whether the source database is left unchanged.

Return Value

Type: ObjectId
Returns the object ID for the new block table record created by this method.
Remarks
Unlike the wblockCloneObjects() method, insert() also copies the sortens table. While copying duplicate objects, names are ignored; a destination object that has the same name as the source object is rewritten by the source one. A new block table record is created and all model space entities of the source database are copied into the new block. You should delete the source database either immediately or at least before the destination database is deleted.
See Also

©  Bricsys NV. All rights reserved.