OdaBlockClassIAcadBlock_AddMInsertBlock Method
|
Namespace: BricscadDb
Assembly: Interop.BricscadDb (in
Interop.BricscadDb.dll) Version: 21.0.0.0
Syntax
public virtual AcadMInsertBlock IAcadBlock_AddMInsertBlock(
Object InsertionPoint,
string Name,
double Xscale,
double Yscale,
double Zscale,
double Rotation,
int NumRows,
int NumColumns,
int RowSpacing,
int ColumnSpacing,
[OptionalAttribute] Object Password
)
Public Overridable Function IAcadBlock_AddMInsertBlock (
InsertionPoint As Object,
Name As String,
Xscale As Double,
Yscale As Double,
Zscale As Double,
Rotation As Double,
NumRows As Integer,
NumColumns As Integer,
RowSpacing As Integer,
ColumnSpacing As Integer,
<OptionalAttribute> Password As Object
) As AcadMInsertBlock
public:
virtual AcadMInsertBlock^ IAcadBlock_AddMInsertBlock(
[InAttribute] Object^ InsertionPoint,
[InAttribute] String^ Name,
[InAttribute] double Xscale,
[InAttribute] double Yscale,
[InAttribute] double Zscale,
[InAttribute] double Rotation,
[InAttribute] int NumRows,
[InAttribute] int NumColumns,
[InAttribute] int RowSpacing,
[InAttribute] int ColumnSpacing,
[OptionalAttribute] [InAttribute] Object^ Password
)
abstract IAcadBlock_AddMInsertBlock :
InsertionPoint : Object *
Name : string *
Xscale : float *
Yscale : float *
Zscale : float *
Rotation : float *
NumRows : int *
NumColumns : int *
RowSpacing : int *
ColumnSpacing : int *
[<OptionalAttribute>] Password : Object -> AcadMInsertBlock
override IAcadBlock_AddMInsertBlock :
InsertionPoint : Object *
Name : string *
Xscale : float *
Yscale : float *
Zscale : float *
Rotation : float *
NumRows : int *
NumColumns : int *
RowSpacing : int *
ColumnSpacing : int *
[<OptionalAttribute>] Password : Object -> AcadMInsertBlock
Parameters
- InsertionPoint
- Type: SystemObject
- Name
- Type: SystemString
- Xscale
- Type: SystemDouble
- Yscale
- Type: SystemDouble
- Zscale
- Type: SystemDouble
- Rotation
- Type: SystemDouble
- NumRows
- Type: SystemInt32
- NumColumns
- Type: SystemInt32
- RowSpacing
- Type: SystemInt32
- ColumnSpacing
- Type: SystemInt32
- Password (Optional)
- Type: SystemObject
Return Value
Type:
AcadMInsertBlock
Implements
IAcadBlockAddMInsertBlock(Object, String, Double, Double, Double,
Double, Int32, Int32, Int32, Int32, Object)
See Also