ApplicationLoadReasons Enumeration

The enumeration that contains reasons to load an application.
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
[FlagsAttribute]
public enum ApplicationLoadReasons
Members
  Member name Value Description
OnProxyDetection 1 Load an application when the custom class objects are loaded by open drawing, dxfin, insert, etc.
OnAutoCADStartup 2 Load the .NET application once the Autodesk(R) AutoCAD(R) is launched.
OnCommandInvocation 4 Load the .NET application when an unknown command is executed for which it has a registry entry.
OnLoadRequest 8 Allow the .NET application to be loaded.
LoadDisabled 16 Do not request to load the .NET application.
TransparentlyLoadable 32 The .NET application should be loaded transparently.
See Also

©  Bricsys NV. All rights reserved.