ArcDimension Constructor (Point3d, Point3d, Point3d, Point3d, String, ObjectId)

Constructor. Creates an ArcDimension object with specified parameters.
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public ArcDimension(
        Point3d centerPoint,
        Point3d xLine1Point,
        Point3d xLine2Point,
        Point3d arcPoint,
        string dimensionText,
        ObjectId dimensionStyle
)

Parameters

centerPoint
Type: Teigha.GeometryPoint3d
Center point of the arc.
xLine1Point
Type: Teigha.GeometryPoint3d
First extension line point.
xLine2Point
Type: Teigha.GeometryPoint3d
Second extension line point.
arcPoint
Type: Teigha.GeometryPoint3d
Point lying on the dimension arc.
dimensionText
Type: SystemString
Dimension text to replace the measured value text.
dimensionStyle
Type: Teigha.DatabaseServicesObjectId
ObjectId of the dimension style that is used to draw the dimension entity.
See Also

©  Bricsys NV. All rights reserved.