Wraps OdCmEntityColor::ColorMethod enum.
Defines the method how the color is specified.
Namespace: Teigha.Colors
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
Public Enumeration ColorMethod
public enum class ColorMethod
Members
|
Member name |
Value |
Description |
|
ByLayer
|
192 |
Value: 0xC0. The color is specified by color of the layer on
which it resides. |
|
ByBlock
|
193 |
Value: 0xC1. The color is specified by color of the block
reference in which it is contained. |
|
ByColor
|
194 |
Value: 0xC2. The color is specified by RGB value. |
|
ByAci
|
195 |
Value: 0xC3. The color is specified by an index (ACI) into a
color table. |
|
ByPen
|
196 |
Value: 0xC4. The color is specified by an index into a pen
color table. |
|
Foreground
|
197 |
Value: 0xC5. The color is specified by foreground color. |
|
LayerOff
|
198 |
Not used. |
|
LayerFrozen
|
199 |
Not used. |
|
None
|
200 |
Value: 0xC8. No color. |
See Also