DatabasePurge Method (ObjectIdGraph)
|
Removes the nodes from the ID graph that are
hard referenced in this database object.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public void Purge(
ObjectIdGraph idGraph
)
Public Sub Purge (
idGraph As ObjectIdGraph
)
public:
void Purge(
ObjectIdGraph^ idGraph
)
member Purge :
idGraph : ObjectIdGraph -> unit
Parameters
- idGraph
- Type: Teigha.DatabaseServicesObjectIdGraph
[in/out] Graph of identifiers to check.
Remarks
This method
builds a reference graph between the objects, which can be used to
remove objects with circular references in one pass. All the
objects referenced from outside of the graph are removed from it on
return. This method does not modify the database.
See Also