CubicSplineCurve2d Constructor (Point2dCollection,
Tolerance)
|
Constructor for the CubicSplineCurve2d class.
Creates a cubic spline curve with the passed fit points.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public CubicSplineCurve2d(
Point2dCollection fitPoints,
Tolerance tolerance
)
Public Sub New (
fitPoints As Point2dCollection,
tolerance As Tolerance
)
public:
CubicSplineCurve2d(
Point2dCollection^ fitPoints,
Tolerance tolerance
)
new :
fitPoints : Point2dCollection *
tolerance : Tolerance -> CubicSplineCurve2d
Parameters
- fitPoints
- Type: Teigha.GeometryPoint2dCollection
[in] Array of fit points.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
See Also