QuadItemRegistryappend Method
|
use this function from inside your
implementation of 'AcEdQuadReactor::registerQuadItems()', to
register all your QuadItems; 'szQuadItemId' should be unique within
the scope of the reactor; 'szLabel', 'szIcon' and 'szCommand'
should not be NULL or empty; 'szTooltip' can be NULL or empty;
returns true if registration was successful
Namespace: Bricscad.Quad
Assembly: BrxMgd (in BrxMgd.dll) Version:
21.0.0.15598
Syntax
public virtual bool append(
string szQuadItemId,
string szLabel,
string szIcon,
string szCommand,
string szTooltip
)
Public Overridable Function append (
szQuadItemId As String,
szLabel As String,
szIcon As String,
szCommand As String,
szTooltip As String
) As Boolean
public:
virtual bool append(
String^ szQuadItemId,
String^ szLabel,
String^ szIcon,
String^ szCommand,
String^ szTooltip
)
abstract append :
szQuadItemId : string *
szLabel : string *
szIcon : string *
szCommand : string *
szTooltip : string -> bool
override append :
szQuadItemId : string *
szLabel : string *
szIcon : string *
szCommand : string *
szTooltip : string -> bool
Parameters
- szQuadItemId
- Type: SystemString
- szLabel
- Type: SystemString
- szIcon
- Type: SystemString
- szCommand
- Type: SystemString
- szTooltip
- Type: SystemString
Return Value
Type:
Boolean
See Also