SymbolUtilityServicesGetPathNameFromSymbolName Method
|
Retrieves the path name from a specified block
name and extension(s). The string extension is appended to the end
of the string if the retrieved string does not have an
extension.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public static string GetPathNameFromSymbolName(
string symbolName,
string extensions
)
Public Shared Function GetPathNameFromSymbolName (
symbolName As String,
extensions As String
) As String
public:
static String^ GetPathNameFromSymbolName(
String^ symbolName,
String^ extensions
)
static member GetPathNameFromSymbolName :
symbolName : string *
extensions : string -> string
Parameters
- symbolName
- Type: SystemString
[in] Name of block from which to get the path.
- extensions
- Type: SystemString
[in] List of extensions for which path names are searched.
Return Value
Type:
String
Path name.
Remarks
The extensions
must be separated by semicolons and should not have dots before
extension names, for example: "dwg;dxf".
See Also