CubicSplineCurve2d Constructor (Point2dCollection, Vector2d,
Vector2d)
|
Constructor for the CubicSplineCurve2d class.
Creates a cubic spline curve with the passed start and end
derivatives, and fit points.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public CubicSplineCurve2d(
Point2dCollection fitPoints,
Vector2d startDerivative,
Vector2d endDerivative
)
Public Sub New (
fitPoints As Point2dCollection,
startDerivative As Vector2d,
endDerivative As Vector2d
)
public:
CubicSplineCurve2d(
Point2dCollection^ fitPoints,
Vector2d startDerivative,
Vector2d endDerivative
)
new :
fitPoints : Point2dCollection *
startDerivative : Vector2d *
endDerivative : Vector2d -> CubicSplineCurve2d
Parameters
- fitPoints
- Type: Teigha.GeometryPoint2dCollection
[in] Array of fit points.
- startDerivative
- Type: Teigha.GeometryVector2d
[in] Starting derivative of the cubic spline curve.
- endDerivative
- Type: Teigha.GeometryVector2d
[in] Ending derivative of the cubic spline curve.
See Also