Checks whether the curve is periodic.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public bool IsPeriodic(
out double period
)
Public Function IsPeriodic (
<OutAttribute> ByRef period As Double
) As Boolean
public:
bool IsPeriodic(
[OutAttribute] double% period
)
member IsPeriodic :
period : float byref -> bool
Parameters
- period
- Type: SystemDouble
[out] Period of the curve parameter.
Return Value
Type:
Boolean
true if this curve is periodic,
false otherwise.
Remarks
The curve is
periodic only if it is closed and returned values for evalPoint(t)
and evalPoint(t+period) are always the same for any passed
parameter t.
See Also