LineAngularDimension2 Constructor (Point3d, Point3d, Point3d, Point3d, Point3d, String, ObjectId)

Constructor. Creates a LineAngularDimension2 object with specified parameters.
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public LineAngularDimension2(
        Point3d line1Start,
        Point3d line1End,
        Point3d line2Start,
        Point3d line2End,
        Point3d arcPoint,
        string dimensionText,
        ObjectId dimensionStyle
)

Parameters

line1Start
Type: Teigha.GeometryPoint3d
Start point of the first definition line.
line1End
Type: Teigha.GeometryPoint3d
End point of the first definition line which is the start point for the first extension line.
line2Start
Type: Teigha.GeometryPoint3d
Start point of the second definition line.
line2End
Type: Teigha.GeometryPoint3d
End point of the second definition line which is the start point for the second extension line.
arcPoint
Type: Teigha.GeometryPoint3d
Point lying on the dimension arc.
dimensionText
Type: SystemString
Dimension text to replace the measured value text.
dimensionStyle
Type: Teigha.DatabaseServicesObjectId
ObjectId of dimension style that is used to draw the dimension entity.
See Also

©  Bricsys NV. All rights reserved.