AssocArrayPolarParameters Constructor (Double, Double, Double, Int32, Int32, Int32, Double)

Constructor for the AssocArrayPolarParameters class. Creates an object with the specified spacing, count, elevation and angle parameters.
Namespace:  Teigha.DatabaseServices
Assembly:  TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public AssocArrayPolarParameters(
        double angle,
        double rowSpacing,
        double levelSpacing,
        int itemCount,
        int rowCount,
        int levelCount,
        double rowElevation
)

Parameters

angle
Type: SystemDouble
[in] Angle created by the two adjacent items and the polar array center. Value can vary from 0 to Oda2PI.
rowSpacing
Type: SystemDouble
[in] Row spacing to set.
levelSpacing
Type: SystemDouble
[in] Level spacing to set.
itemCount
Type: SystemInt32
[in] Item count of the array.
rowCount
Type: SystemInt32
[in] Row count of the array.
levelCount
Type: SystemInt32
[in] Level count of the array.
rowElevation
Type: SystemDouble
[in] Row elevation between adjacent rows of the array.
See Also

©  Bricsys NV. All rights reserved.