Curve2dGetTrimmedOffset Method (Double, OffsetCurveExtensionType)

Retrieves offset curves that represent the trimmed offset of the curve.
Namespace:  Teigha.Geometry
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public Curve2d[] GetTrimmedOffset(
        double distance,
        OffsetCurveExtensionType extensionType
)

Parameters

distance
Type: SystemDouble
[in] Offset distance.
extensionType
Type: Teigha.GeometryOffsetCurveExtensionType
[in] Determines how the offset curve will be extended at points of C1 discontinuity.

Return Value

Type: Curve2d
Array that stores offset curves.
See Also

©  Bricsys NV. All rights reserved.