OdaBlockClassIAcadBlock_InsertBlock Method
|
Namespace: BricscadDb
Assembly: Interop.BricscadDb (in
Interop.BricscadDb.dll) Version: 21.0.0.0
Syntax
public virtual AcadBlockReference IAcadBlock_InsertBlock(
Object InsertionPoint,
string Name,
double Xscale,
double Yscale,
double Zscale,
double Rotation,
[OptionalAttribute] Object Password
)
Public Overridable Function IAcadBlock_InsertBlock (
InsertionPoint As Object,
Name As String,
Xscale As Double,
Yscale As Double,
Zscale As Double,
Rotation As Double,
<OptionalAttribute> Password As Object
) As AcadBlockReference
public:
virtual AcadBlockReference^ IAcadBlock_InsertBlock(
[InAttribute] Object^ InsertionPoint,
[InAttribute] String^ Name,
[InAttribute] double Xscale,
[InAttribute] double Yscale,
[InAttribute] double Zscale,
[InAttribute] double Rotation,
[OptionalAttribute] [InAttribute] Object^ Password
)
abstract IAcadBlock_InsertBlock :
InsertionPoint : Object *
Name : string *
Xscale : float *
Yscale : float *
Zscale : float *
Rotation : float *
[<OptionalAttribute>] Password : Object -> AcadBlockReference
override IAcadBlock_InsertBlock :
InsertionPoint : Object *
Name : string *
Xscale : float *
Yscale : float *
Zscale : float *
Rotation : float *
[<OptionalAttribute>] Password : Object -> AcadBlockReference
Parameters
- InsertionPoint
- Type: SystemObject
- Name
- Type: SystemString
- Xscale
- Type: SystemDouble
- Yscale
- Type: SystemDouble
- Zscale
- Type: SystemDouble
- Rotation
- Type: SystemDouble
- Password (Optional)
- Type: SystemObject
Return Value
Type:
AcadBlockReference
Implements
IAcadBlockInsertBlock(Object, String, Double, Double, Double,
Double, Object)
See Also