Curve2dIsLinear Method (Line2d, Tolerance)
|
Checks whether this curve is linear within a
specified tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public bool IsLinear(
out Line2d line,
Tolerance tolerance
)
Public Function IsLinear (
<OutAttribute> ByRef line As Line2d,
tolerance As Tolerance
) As Boolean
public:
bool IsLinear(
[OutAttribute] Line2d^% line,
Tolerance tolerance
)
member IsLinear :
line : Line2d byref *
tolerance : Tolerance -> bool
Parameters
- line
- Type: Teigha.GeometryLine2d
[out] Receives the line coincident with this curve.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
Boolean
true if this curve is linear,
false otherwise.
Remarks
The line parameter cannot have a relevant data if the
method returns false.
See Also