Curve2dGetParameterAtLength Method (Double, Double, Boolean,
Tolerance)
|
Retrieves the parameter value of the point
whose arc length distance is the input length.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public double GetParameterAtLength(
double datumParameter,
double length,
bool parameterDirection,
Tolerance tolerance
)
Public Function GetParameterAtLength (
datumParameter As Double,
length As Double,
parameterDirection As Boolean,
tolerance As Tolerance
) As Double
public:
double GetParameterAtLength(
double datumParameter,
double length,
bool parameterDirection,
Tolerance tolerance
)
member GetParameterAtLength :
datumParameter : float *
length : float *
parameterDirection : bool *
tolerance : Tolerance -> float
Parameters
- datumParameter
- Type: SystemDouble
[in] Parameter value.
- length
- Type: SystemDouble
[in] Sub-interval of the curve.
- parameterDirection
- Type: SystemBoolean
[in] Parameter direction.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
Double
Parameter value as the
double type.
See Also