AttributeDefinition Constructor (Point3d, String, String,
String, ObjectId)
|
Builds a new instance of the
AttributeDefinition class with specified parameters.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public AttributeDefinition(
Point3d position,
string value,
string tag,
string prompt,
ObjectId style
)
Public Sub New (
position As Point3d,
value As String,
tag As String,
prompt As String,
style As ObjectId
)
public:
AttributeDefinition(
Point3d position,
String^ value,
String^ tag,
String^ prompt,
ObjectId style
)
new :
position : Point3d *
value : string *
tag : string *
prompt : string *
style : ObjectId -> AttributeDefinition
Parameters
- position
- Type: Teigha.GeometryPoint3d
Position of the AttributeDefinition entity.
- value
- Type: SystemString
Value string of the AttributeDefinition entity.
- tag
- Type: SystemString
Tag string of the AttributeDefinition entity.
- prompt
- Type: SystemString
Prompt string of the AttributeDefinition entity.
- style
- Type: Teigha.DatabaseServicesObjectId
Style of the AttributeDefinition entity.
See Also