SymbolUtilityServicesRepairSymbolName Method
|
Retrieves a string which is the result of
"repairing" the passed string. The method calls the
validatePreExtendedSymbolname() and validateSymbolName() methods to
properly repair the passed string. As a result, the returned string
contains only valid characters.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public static string RepairSymbolName(
string oldName,
bool allowVerticalBar
)
Public Shared Function RepairSymbolName (
oldName As String,
allowVerticalBar As Boolean
) As String
public:
static String^ RepairSymbolName(
String^ oldName,
bool allowVerticalBar
)
static member RepairSymbolName :
oldName : string *
allowVerticalBar : bool -> string
Parameters
- oldName
- Type: SystemString
[in] Name to repair.
- allowVerticalBar
- Type: SystemBoolean
[in] Flag that specifies whether vertical bars ("|") are allowed in
the symbol name.
Return Value
Type:
String
A repaired symbol name.
See Also