CubicSplineCurve3d Constructor (Point3dCollection,
Tolerance)
|
Constructor for the CubicSplineCurve3d class.
Creates a cubic spline curve with the passed points.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public CubicSplineCurve3d(
Point3dCollection points,
Tolerance tolerance
)
Public Sub New (
points As Point3dCollection,
tolerance As Tolerance
)
public:
CubicSplineCurve3d(
Point3dCollection^ points,
Tolerance tolerance
)
new :
points : Point3dCollection *
tolerance : Tolerance -> CubicSplineCurve3d
Parameters
- points
- Type: Teigha.GeometryPoint3dCollection
[in] Array of points.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
See Also