DiametricDimension Constructor (Point3d, Point3d, Double,
String, ObjectId)
|
Constructor. Creates a DiametricDimension
object with specified parameters.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public DiametricDimension(
Point3d chordPoint,
Point3d farChordPoint,
double leaderLength,
string dimensionText,
ObjectId dimensionStyle
)
Public Sub New (
chordPoint As Point3d,
farChordPoint As Point3d,
leaderLength As Double,
dimensionText As String,
dimensionStyle As ObjectId
)
public:
DiametricDimension(
Point3d chordPoint,
Point3d farChordPoint,
double leaderLength,
String^ dimensionText,
ObjectId dimensionStyle
)
new :
chordPoint : Point3d *
farChordPoint : Point3d *
leaderLength : float *
dimensionText : string *
dimensionStyle : ObjectId -> DiametricDimension
Parameters
- chordPoint
- Type: Teigha.GeometryPoint3d
The three-dimensional WCS coordinates that define the chord point
on the circle or arc to be measured, and to which the dimension
line is drawn.
- farChordPoint
- Type: Teigha.GeometryPoint3d
The three-dimensional WCS coordinates that define the far chord
point, opposite the chord point, on the circle or arc to be
measured.
- leaderLength
- Type: SystemDouble
The distance from the chord point to the dogleg of the dimension (a
positive non-zero value).
- dimensionText
- Type: SystemString
Dimension text to replace the measured value text.
- dimensionStyle
- Type: Teigha.DatabaseServicesObjectId
ObjectId of the dimension style that is used to draw the dimension
entity.
See Also