BulgeVertexCollection Class |
The BulgeVertexCollection type exposes the following members.
Name | Description | |
---|---|---|
![]() |
BulgeVertexCollection |
Initializes a new instance of the BulgeVertexCollection class
|
Name | Description | |
---|---|---|
![]() |
Capacity |
Gets or sets the number of elements that the
CollectionBase can contain.
(Inherited from CollectionBase.) |
![]() |
Count |
Gets the number of elements contained in the
CollectionBase instance. This property cannot
be overridden.
(Inherited from CollectionBase.) |
![]() |
InnerList |
Gets an ArrayList containing the list of elements in
the CollectionBase instance.
(Inherited from CollectionBase.) |
![]() |
Item | |
![]() |
List |
Gets an IList containing the list of elements in the
CollectionBase instance.
(Inherited from CollectionBase.) |
Name | Description | |
---|---|---|
![]() |
Add | |
![]() |
Clear |
Removes all objects from the CollectionBase instance. This method cannot be
overridden.
(Inherited from CollectionBase.) |
![]() |
Contains | |
![]() |
CopyTo | |
![]() |
Equals | (Inherited from Object.) |
![]() |
Finalize |
Allows an object to try to free resources and
perform other cleanup operations before it is reclaimed by garbage
collection.
(Inherited from Object.) |
![]() |
GetEnumerator |
Returns an enumerator that iterates through
the CollectionBase instance.
(Inherited from CollectionBase.) |
![]() |
GetHashCode |
Serves as a hash function for a particular
type.
(Inherited from Object.) |
![]() |
GetType |
Gets the Type of the current instance.
(Inherited from Object.) |
![]() |
IndexOf | |
![]() |
Insert | |
![]() |
MemberwiseClone |
Creates a shallow copy of the current Object.
(Inherited from Object.) |
![]() |
OnClear |
Performs additional custom processes when
clearing the contents of the CollectionBase instance.
(Inherited from CollectionBase.) |
![]() |
OnClearComplete |
Performs additional custom processes after
clearing the contents of the CollectionBase instance.
(Inherited from CollectionBase.) |
![]() |
OnInsert |
Performs additional custom processes before
inserting a new element into the CollectionBase instance.
(Inherited from CollectionBase.) |
![]() |
OnInsertComplete |
Performs additional custom processes after
inserting a new element into the CollectionBase instance.
(Inherited from CollectionBase.) |
![]() |
OnRemove |
Performs additional custom processes when
removing an element from the CollectionBase instance.
(Inherited from CollectionBase.) |
![]() |
OnRemoveComplete |
Performs additional custom processes after
removing an element from the CollectionBase instance.
(Inherited from CollectionBase.) |
![]() |
OnSet |
Performs additional custom processes before
setting a value in the CollectionBase instance.
(Inherited from CollectionBase.) |
![]() |
OnSetComplete |
Performs additional custom processes after
setting a value in the CollectionBase instance.
(Inherited from CollectionBase.) |
![]() |
OnValidate | (Overrides CollectionBaseOnValidate(Object).) |
![]() |
Remove | |
![]() |
RemoveAt |
Removes the element at the specified index of
the CollectionBase instance. This method is not
overridable.
(Inherited from CollectionBase.) |
![]() |
ToString |
Returns a string that represents the current
object.
(Inherited from Object.) |
© Bricsys NV. All rights reserved. |