Curve2dIsDegenerate Method (Entity2d)
|
Checks whether this curve is degenerate and
returns the type of entity that the curve degenerates to (if
degenerate).
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public bool IsDegenerate(
out Entity2d result
)
Public Function IsDegenerate (
<OutAttribute> ByRef result As Entity2d
) As Boolean
public:
bool IsDegenerate(
[OutAttribute] Entity2d^% result
)
member IsDegenerate :
result : Entity2d byref -> bool
Parameters
- result
- Type: Teigha.GeometryEntity2d
[out] Retrieves the type of degenerate entity.
Return Value
Type:
Boolean
true if this curve is degenerate,
false otherwise.
See Also