Curve2dGetLength Method (Double, Double, Tolerance)
|
Retrieves the arc length of the curve between
the two parameter values within a specified tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public double GetLength(
double fromParameter,
double toParameter,
Tolerance tolerance
)
Public Function GetLength (
fromParameter As Double,
toParameter As Double,
tolerance As Tolerance
) As Double
public:
double GetLength(
double fromParameter,
double toParameter,
Tolerance tolerance
)
member GetLength :
fromParameter : float *
toParameter : float *
tolerance : Tolerance -> float
Parameters
- fromParameter
- Type: SystemDouble
[in] First parameter value that represents the start of the
interval.
- toParameter
- Type: SystemDouble
[in] Second parameter value that represents the end of the
interval.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometric tolerance.
Return Value
Type:
Double
The length as a value of the double type.
See Also