CircularArc3dGetTangent Method (Point3d, Tolerance)
|
Retrieves the tangent line at the specified
point.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public Line3d GetTangent(
Point3d pointValue,
Tolerance tolerance
)
Public Function GetTangent (
pointValue As Point3d,
tolerance As Tolerance
) As Line3d
public:
Line3d^ GetTangent(
Point3d pointValue,
Tolerance tolerance
)
member GetTangent :
pointValue : Point3d *
tolerance : Tolerance -> Line3d
Parameters
- pointValue
- Type: Teigha.GeometryPoint3d
[in] Point at which the tangent line is calculated.
- tolerance
- Type: Teigha.GeometryTolerance
[in] Geometry tolerance.
Return Value
Type:
Line3d
Tangent 3D line represented by the Line3d class.
See Also