CircularArc2d Constructor (Point2d, Point2d, Point2d)
|
Constructor for the CircularArc2d class.
Creates an arc with the specified three points.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public CircularArc2d(
Point2d startPoint,
Point2d point,
Point2d endPoint
)
Public Sub New (
startPoint As Point2d,
point As Point2d,
endPoint As Point2d
)
public:
CircularArc2d(
Point2d startPoint,
Point2d point,
Point2d endPoint
)
new :
startPoint : Point2d *
point : Point2d *
endPoint : Point2d -> CircularArc2d
Parameters
- startPoint
- Type: Teigha.GeometryPoint2d
[in] Start point of an arc.
- point
- Type: Teigha.GeometryPoint2d
[in] Second point on a 3-point arc.
- endPoint
- Type: Teigha.GeometryPoint2d
[in] End point of an arc.
See Also