Curve2dGetParameterAtLength Method (Double, Double, Boolean)
|
Retrieves the parameter value of the point
whose arc length distance is the input length.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
21.4.0.0
Syntax
public double GetParameterAtLength(
double datumParameter,
double length,
bool parameterDirection
)
Public Function GetParameterAtLength (
datumParameter As Double,
length As Double,
parameterDirection As Boolean
) As Double
public:
double GetParameterAtLength(
double datumParameter,
double length,
bool parameterDirection
)
member GetParameterAtLength :
datumParameter : float *
length : float *
parameterDirection : bool -> float
Parameters
- datumParameter
- Type: SystemDouble
[in] Parameter value.
- length
- Type: SystemDouble
[in] Sub-interval of the curve.
- parameterDirection
- Type: SystemBoolean
[in] Parameter direction.
Return Value
Type:
Double
Parameter value as the
double type.
See Also