AlignedDimension Constructor (Point3d, Point3d, Point3d, String, ObjectId)

Constructor. Creates an AlignedDimension object with specified parameters.
Namespace:  Teigha.DatabaseServices
Assembly:  TD_Mgd (in TD_Mgd.dll) Version: 21.4.0.0
Syntax
public AlignedDimension(
        Point3d line1Point,
        Point3d line2Point,
        Point3d dimensionLinePoint,
        string dimensionText,
        ObjectId dimensionStyle
)

Parameters

line1Point
Type: Teigha.GeometryPoint3d
First extension point. The point from which the length is measured and the first extension line begins.
line2Point
Type: Teigha.GeometryPoint3d
Second extension point. The point to which the length is measured and from which the second extension line begins.
dimensionLinePoint
Type: Teigha.GeometryPoint3d
Point lying on the dimension line.
dimensionText
Type: SystemString
Dimension text to replace the measured value text.
dimensionStyle
Type: Teigha.DatabaseServicesObjectId
ObjectId of the dimension style that is used to draw the dimension entity.
See Also

©  Bricsys NV. All rights reserved.