AcadSplineClassSetNurbsData Method
|
Namespace: BricscadDb
Assembly: Interop.BricscadDb (in
Interop.BricscadDb.dll) Version: 21.0.0.0
Syntax
public virtual void SetNurbsData(
int Degree,
Object ControlPoints,
Object Knots,
Object Weights,
double controlPtTolerance,
double knotTolerance,
bool periodic
)
Public Overridable Sub SetNurbsData (
Degree As Integer,
ControlPoints As Object,
Knots As Object,
Weights As Object,
controlPtTolerance As Double,
knotTolerance As Double,
periodic As Boolean
)
public:
virtual void SetNurbsData(
[InAttribute] int Degree,
[InAttribute] Object^ ControlPoints,
[InAttribute] Object^ Knots,
[InAttribute] Object^ Weights,
[InAttribute] double controlPtTolerance,
[InAttribute] double knotTolerance,
[InAttribute] bool periodic
)
abstract SetNurbsData :
Degree : int *
ControlPoints : Object *
Knots : Object *
Weights : Object *
controlPtTolerance : float *
knotTolerance : float *
periodic : bool -> unit
override SetNurbsData :
Degree : int *
ControlPoints : Object *
Knots : Object *
Weights : Object *
controlPtTolerance : float *
knotTolerance : float *
periodic : bool -> unit
Parameters
- Degree
- Type: SystemInt32
- ControlPoints
- Type: SystemObject
- Knots
- Type: SystemObject
- Weights
- Type: SystemObject
- controlPtTolerance
- Type: SystemDouble
- knotTolerance
- Type: SystemDouble
- periodic
- Type: SystemBoolean
Implements
IOdaSplineSetNurbsData(Int32, Object, Object, Object, Double,
Double, Boolean)
See Also