tblsearch


(tblsearch table entryName [ setForNext ] )

This function returns the definition data for entryName in specified table.

Arguments

table  (string) the name of the table
symbol  (string) the name of the table entry to retrieve
setForNext  (NIL/non-NIL, optional) if present and not NIL, the next (tblnext) call will use this position as start point

Return

the (entget) style definition list; NIL if no more record is present in table (at the end of iteration);
returns NIL if the entryName is not found in table

Example

(tblsearch "Layer" "0" T)
((0 . "LAYER") (2 . "0") (70 . 0) (62 . 7) (6 . "Continuous"))

Remarks

see (tblnext) and (tblobjname) functions;



©  Bricsys NV. All rights reserved.