vle-tblsearch


(vle-tblsearch  tblname  itemname)

verifies whether the table 'tblname' contains an entry 'itemname'

Arguments

tblname  name (string) of the table to search in

itemname  the entry name to search for

Return

 T   if the table 'tblname' does contain 'itemname'
NIL if the table 'tblname' does not contain 'itemname'

Example

(vle-tblsearch "LAYER" "xx")
returns the T if the layer table contains layer "xx", NIL otherwise

Alias


Remarks

fast replacement for (/= (tblobjname tblname itemname) nil) and (if (tblsearch tblname itemname) ...)



©  Bricsys NV. All rights reserved.