vlisp-export-symbol
(vlisp-export-symbol
symbolOrList)
This function exports the specified symbol /
variable (or the list of symbols / variables) to the global
document namespace (where normal Lisp code is
operating);
then those symbols / variables are accessible
from any other normal Lisp code and function.
It exports the actual value of the symbol /
variable, not a "reference" to the symbol / variable !
If the value is changed within the VLX
NameSpace code, the symbol / variable need to be re-exported
again.
see (vl-doc-set)
Arguments |
symbolOrList a single Lisp symbol (string or symbol) or a list of Lisp symbols |
Return |
the value of the last evaluated symbol / variable |
Example |
(vlisp-export-symbol 'MyVar1)
returns the value of "MyVar1" |
Alias |
|
Remarks |
if (vlisp-export-symbol) is
called from the global document namespace, then it does nothing and
returns the value of the last evaluated symbol /
variable; |
© Bricsys NV. All rights reserved. |