AttachExternalReference method

Attaches a specified drawing as an ExternalReference.

 

Syntax

objectVariable = object.AttachExternalReference(PathName, [Name], [InsertionPoint], [XScale], [YScale], [Zscale], [Rotation], [bOverlay])

Where:

     object is one of the ModelSpace or PaperSpace collection objects or a Block object;

     PathName is a string representing the full path and file name of the drawing;

     Name is a string representing the name of external reference to be created;

     InsertionPoint is a Point object representing the point at which the drawing will be inserted;

     XScale, YScale, and ZScale are double-precision variables (or values) representing the scaling factors for the drawing along each coordinate plane;

     Rotation is a double-precision variable (or value) representing the rotation angle (in radians) for the external reference;

     bOverlay is a Boolean variable (or value) indicating whether the reference is an overlay or attachment

TRUE:     The xref instance is an overlay.

FALSE:     The xref instance is an attachment.

 

Examples...

AttachExternalReference method example

 


© Bricsys NV. All rights reserved.