apply


(apply  'function  list)

This function passes the arguments provided as list to the function  and evaluates the function using these arguments.

Arguments

'function  a functiony type argument (defun or lambda or native Lisp function)

list  list of arguments passed to function; can be NIL, depending on the target function

Return

the result of evaluating function using the arguments from list

Example

(apply  '*  '(2 3 4))
24
(apply  'strcat  '("one" " " "two" " " "three"))
"one two three"

Remarks




©  Bricsys NV. All rights reserved.