bim:delete-propertyset
(bim:delete-propertyset name
[categoryId | categoryName])
This functions deletes the specified
PropertySet name from the (optionally) specified NameSpace.
Arguments
|
name (string) the name of the PropertySet to be deleted
(can specify the "name" or the "label" of a PropertySet)
(optional)
specifies the NameSpace to remove the
PropertySet from (each category has an associated
NameSpace)
categoryId BIM property category ID, can be omitted
(bcBimCategoryUser is used then); see Category Constants
---or---
categoryName BIM category name as string (can be an empty string
for bcBimCategoryUser), see Category Constants
if omitted, the "User" NameSpace is
automatically used
|
Return
|
T or NIL, indicating success
or failure
|
Example
|
(bim:delete-propertyset
"TestSet") NIL
(bim:create-propertyset "TestSetZ"
"---testZ---" T T "MyPropertyNameSpace") T
(bim:delete-propertyset "TestSet")
NIL
(bim:delete-propertyset "TestSetZ"
"MyPropertyNameSpace") T
|
Remarks
|
the PropertySet name/label is
case-insensitive;
if the NameSpace (as indirectly specified by
categoryId resp. categoryName) does not exist, NIL is
returned;
Please note, that some of the predefined,
built-in PropertySet(s) can not be deleted
|