bim:get-allspaces


(bim:get-allspaces  [building  [story]])       (since V21)

Returns a list of all BIM spaces, optionally for specified building and story.

Arguments

building  (optional) name of the building (string) to retrieve all spaces from

story  (optional) name of the building (string) to retrieve all spaces from

if story is not specified, then all spaces of given building are returned
if building is not specified, then all spaces of the entire drawing are returned

Return

list of spaces entities if any room is available, or NIL if no room is available

Example

(bim:get-allspaces)  (<ename> ... <ename>)  returns all spaces for the actual drawing
(bim:get-allspaces "Tower")  (<ename> ... <ename>)  returns all spaces for the "Tower" building
(bim:get-allspaces "Tower" "Floor-1")  (<ename> ... <ename>)  returns all spaces for the "Floor-1" story in "Tower" building

Remarks

see (bim::create-space);
the building and story name strings are case-sensitive !



©  Bricsys NV. All rights reserved.