dos_dir


(dos_dir  [filespec  [sort]])

Returns a list of all file names matching the filespec as sorted or unsorted list, due to sort argument.

filespec : specifies a file mask/filter, can contain path specification, and wildcards for the file name;

if filespec does not contain a path, the current working directory is used;
if filespec does not contain a mask for the file names, the default "*.*" is used (resp. "*" for Linux/Mac)
(the "*.*" and "*" are automatically handled by the Lisp engine, so using "*.*" and "*" are all valid, on all platforms)

sort : specifies whether and how the file names are sorted
0 no sorting
1 alphabetically ascending
2 alphabetically descending
3 by date ascending
4 by date descending
5 by size ascending
6 by size descending

Returns the list of directories and subdirectories, or NIL on error.

Examples :
(dos_dir  "/home/mint/*.*")
(dos_dir  "/home/mint/*.*"  1)
(dos_dir "c:\\Downloads\\*.*" 5)
(dos_dir "c:/Downloads/*.*" 6)


©  Bricsys NV. All rights reserved.