dos_getfilem
(dos_getfilem title folder
filter)
Opens BricsCAD's FileSelection dialog to let
the user select one or multiple file(s).
title : is the
FileSelect dialog title
folder : preset
folder to be used for file selection; user can change to any other
folder
filter : a string
containing of file specification tokens - a token has the
form "any description
|*.xxx|", multiple tokens can be
combined;
to indicate that the tokens sequence is
finished, add an extra "|" as last character.
Note : under
BricsCAD, a simplified filter can be used - simply combine all file
type extensions by comma or semicolon : "dwg;txt"
Returns a list of selected files when
successful, or NIL if dialog was cancelled or failed
Note 1 : the first
entry of the list is the folder name !
Note 2 : the
number of files being selected is limited to ~6000 files
!
Example :
(dos_getfilem "Select Drawings or Text
files" "C:\\Projects\\" "Drawing Files (dwg)|*.dwg|Text
Files (*.txt)|*.txt||")
will return a list like
("C:\\Projects\\Stadium\\" "entry.dwg"
"places.dwg" "readme.txt")
© Bricsys NV. All rights reserved. |